Forum change gotchas. Add yours.

Started by klondike, May 28, 2022, 06:26:24 AM

« previous - next »

klondike

Font size
Not everybody will get this.

Reason - feel free to skip this bit
The size is governed by a set of CSS files. In this case ....
https://letschat.club/Themes/default/css/index.css
I had to edit that manually.
Modern software tries to speed up websites and in the case of the forum it combines the various CSS files, removes all extra spaces and produces a single file. Right now that single file is  ...
https://letschat.club/Themes/default/css/minified_007b381a33411aacdc684cbf1a62af5a.css?smf212_1653678170
The forum code produces a cache where that gets stored so it only need do it once.
When this site is accessed Cloudflare caches a bunch of files too - images and CSS files.
So after I edited the CSS file to increase size I had to flush the forum cache and flush the Cloudflare cache.
Before that got completed some of you accessed or tried to access the forum and got one of the older cached versions then your browsers cached that so you may have ended up with the default sizes.

How to fix it
Several ways some easier than others and some  more sure to work than others.
Simplest to try is to just refresh the browser page. Usually F5 will do that.
Surest is to refresh the browser cache which varies from browser to browser and you may need to ask google
https://www.google.com/search?q=how+do+I+refresh+my+browser+cache

Stuff has moved where is it?
There is a new menu bar right at the top of the forum and options appear when clicked. 
  • A bunch of stuff on preferences are under your userid including logout.
  • Private Messaging menu
  • Alerts options

I'm posting and a bunch of smilies are overlaying stuff
With the old code the Extra Smilies screen sat in the background once used if you clicked the post area again. Annoyingly it no longer does that and you'll need to use the scrollbar on the right gto get to the bottom of it and click close. Maybe those huge smilies were a bad idea. I've moved some of the smaller extras into the main area and will downsize the big ones a bit later to try to remove the need to scroll. I'll delete a few that I haven't seen used much or are too big as well.





It's good to moan.

Raven


klondike

I have increased the font sizes in the posting boxes too now.

To get round the extra icons exceeding the window that opens for them so requiring scrolling to close it I had two choices - reduce the number of smileys or resize the big ones, I did both and removed some of the little used ones and reduced the outsize ones to closer to the rest. I also moved some of the popular ones from the extra set into the standard ones.

It's good to moan.

Michael Rolls

Thank you for the days, the days you gave me
[email protected]

klondike

If those changes aren't showing for anybody who reads this they'll need to flush their browser cache. How varies from browser to browser so ask google. You may need to add your browser name to this query

https://www.google.co.uk/search?q=how+to+flush+browser+cache&hl=en

It looks like the key combination CTRL SHIFT DEL is recognised by several browsers to bring up the correct option page which I never new. I use Brave and it worked with that. I expect I'll forgotten that again by next week though.


It's good to moan.

Alex

The Font size for me was ok to read but until I click on REPLY it's really small type in the white box. 

klondike

#6
I updated that. For me it is about the same size in both now. Try flushing cache as mentioned above.

It is smaller on my tablet. I'm guessing that you are using a mobile device. I'll try to find which CSS file governs it there. It's easy to find on the desktop as the browser has an "inspect" command but I don't find one on this tablet.

I didn't notice earlier as it is big enough on this but certainly smaller

It's good to moan.

Alex

I use a laptop Klondy, not a real problem .

klondike

I think I've fixed it. Try yours again




It's good to moan.

Alex


Raven

Is there any way I can shut out the quick reply box, like I can with the info centre? I'm so used to just clicking on reply, and having this one already there is confusing and annoying.

klondike

I've seen several double posts which I think were caused by it. I can't see a way to turn it off but will check some more because I agree that it is unnecessary.

It's good to moan.

klondike

I found a suggestion to make a manual code change to remove it. That does work but it also disables the quick edit button which is even more annoying. I'll have to reverse that bodge. Sorry.

This was the discussion
https://www.simplemachines.org/community/index.php?topic=571853.0

It's good to moan.

Michael Rolls

I didn't even realise that there is a 'Quick reply' never (until now) scroll down past 'Reply'
Mike
Thank you for the days, the days you gave me
[email protected]

klondike

I tried to find a decent Benny Hill "Learning all the time" pic but couldn't although the catchphrase was mentioned.

So an alternative...


It's good to moan.